Внимание! В связи с нестабильным курсом валют цена на сайте может быть неактуальной. Уточняйте стоимость у менеджера.

пн-пт/9:00 - 19:00

Команды маршрутизаторов Cisco

02.08.2021

Содержание статьи:

  1. Команды маршрутизатора для начальной настройки
  2. Базовые команды для настройки маршрутизатора Cisco
  3. Команды маршрутизатора Cisco для настройки интерфейса
    1. Команды маршрутизатора Cisco для работы с интерфейсами – пример настройки
  4. Проверка настроек портов
  5. Работа с таблицей маршрутизации роутера
  6. Взаимодействие с флэш-памятью и NVRAM


Базовая настройка работы маршрутизатора начинается с осуществления действий, выполняемых в режиме настройки роутера. Ниже мы разберем базовые команды для настройки маршрутизатора компании Cisco, а также примеры их применения. Стоит отметить, что роутеры этого бренда имеют много отличительных особенностей, касающихся настройки, однако их популярность требует от сетевого администратора и других специалистов владеть перечнем команд, требующихся наиболее часто.

Команды маршрутизатора для начальной настройки

Чтобы перейти в режим конфигурирования устройства, следует прописать команду configure terminal. При этом нужно задать такие параметры:

  1. Имя роутера: Router(config)# hostname
  2. Пароль для входа в режим администрирования: Router(config)# enable secret password
  3. Пароль для консольного входа:
              Router(config)# line console 0 
            Router(config-line)# password password 
            Router(config-line)# login  
            
  4. Код удаленного доступа (Telnet/SSH):
                Router(config-line)# line vty 0 4 
    Router(config-line)# password password
    Router(config-line)# login
    Router(config-line)# transport input {ssh | telnet}
            
  5. Шифрование паролей:
             Router(config-line)# exit 
    Router(config)# service password-encryption   
           
  6. Предупреждение о несанкционированном подключении – выводится в виде баннера при активации подключения к маршрутизатору: Router(config)# banner motd delimiter message delimiter
  7. Сохранение:
    Router(config)# end 
    Router# copy running-config startup-config
        

Базовые команды для настройки маршрутизатора Cisco

Разберем пример, в котором покажем команды для настройки маршрутизатора Cisco. Возьмем роутер, обозначенный R1 и проведем его первичную настройку.

Начнем с команд:

   Router> enable 
Router# configure terminal 
Enter configuration commands, one per line. 
End with CNTL/Z. 
Router(config)# hostname R1 
R1(config)# 

В силу того, что привилегированный режим позволяет управлять настройками роутера на правах администратора, доступ к нему должен быть надежно защищен. Поэтому шифрованию следует уделять особое внимание.

С этой целью можно применить следующую цепочку команд:

    R1(config)# enable secret class 
    R1(config)# 
    R1(config)# line console 0 
    R1(config-line)# password cisco 
    R1(config-line)# login 
    R1(config-line)# exit 
    R1(config)#
    R1(config)# line vty 0 4
    R1(config-line)# password cisco
    R1(config-line)# login
    R1(config-line)# transport input ssh telnet
    R1(config-line)# exit
    R1(config)#
    R1(config)# service password-encryption
    R1(config)#

Таким образом, мы защитим режимы пользователя и администратора, активируем Telnet/SSH и надежно защитим все пароли шифрованием.

Следующим шагом будет настройка баннера, предупреждающего о юридической ответственности за несанкционированный вход. Баннер имеет название Message of the Day и говорит о том, что лишь авторизованные лица имеют доступ к маршрутизатору. Введем следующие команды:

    R1(config)# banner motd # 
Enter TEXT message. End with a new line and the #
***********************************************
WARNING: Unauthorized access is prohibited!
***********************************************
#
R1(config)#

Команды маршрутизатора Cisco для настройки интерфейса

После первичной настройки следует продолжить конфигурировать роутер. Слеующий этап – настройка интерфейсов, которая выполняется для предоставления доступа к устройству для других пользователей. Маршрутизаторы Cisco оснащаются различными интерфейсами. Например, в модели ISR 4321 два интерфейса:

  • GigabitEthernet 0/0/0;
  • GigabitEthernet 0/0/1.

Настройка интерфейсов проводится посредством ввода команд:

    Router(config)# interface type-and-number
Router(config-if)# description description-text
Router(config-if)# ip address ipv4-address subnet-mask
Router(config-if)# ipv6 address ipv6-address/prefix-length
Router(config-if)# no shutdown

После активации порта вы увидите уведомление об этом в консольном окне.

Команда Description не является обязательной для активации интерфейса, но ею лучше не пренебрегать. Текстовая длина данной команды равна 240 символам. Если речь идет о ликвидации неполадок в работе производственных сетей, информация о типе сетевого подключения будет полезной. Это может быть, например, если необходимо подключить интерфейс к провайдеру. Здесь необходимо будет ввести внешнее соединение и информацию о контакте.

Включение интерфейса (по аналогии включения питания) задается командой no shutdown. При подключении роутера к другому устройству появится физическая связь. Также команда будет полезна в следующих ситуациях:

  • работа в режиме конфигурации;
  • диагностика либо настройка новых интерфейсов;
  • проблемы, возникающие в отношении интерфейсов (в этом случае можно использовать shut или no shut).

Команды маршрутизатора Cisco для работы с интерфейсами – пример настройки

На роутере R1 активируем подключенные порты. Настройка портов будет проведена следующим образом:

  R1> enable
R1# configure terminal
Enter configuration commands, one per line.
End with CNTL/Z.
R1(config)# interface gigabitEthernet 0/0/0
R1(config-if)# description Link to LAN
R1(config-if)# ip address 192.168.10.1 255.255.255.0
R1(config-if)# ipv6 address 2001:db8:acad:10::1/64
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)#
*Aug 1 01:43:53.435: %LINK-3-UPDOWN: Interface GigabitEthernet0/0/0, changed state to down
*Aug 1 01:43:56.447: %LINK-3-UPDOWN: Interface GigabitEthernet0/0/0, changed state to up
*Aug 1 01:43:57.447: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0/0, changed state to up
R1(config)#
R1(config)#
R1(config)# interface gigabitEthernet 0/0/1
R1(config-if)# description Link to R2
R1(config-if)# ip address 209.165.200.225 255.255.255.252
R1(config-if)# ipv6 address 2001:db8:feed:224::1/64
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)#
*Aug 1 01:46:29.170: %LINK-3-UPDOWN: Interface GigabitEthernet0/0/1, changed state to down
*Aug 1 01:46:32.171: %LINK-3-UPDOWN: Interface GigabitEthernet0/0/1, changed state to up
*Aug 1 01:46:33.171: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0/1, changed state to up
R1(config)#  

После этого мы получим мэсэнджи о том, что порты подключены.

Проверка настроек портов

Базовые и наиболее целевые команды маршрутизатора для проверок портов имеют следующий вид:

  • show ip interface brief;
  • show ipv6 interface brief.

Покажем на примере:

R1#  show ip interface brief
Interface              IP-Address  	OK? Method Status            	Protocol
GigabitEthernet0/0/0   192.168.10.1	YES manual up                	up
GigabitEthernet0/0/1   209.165.200.225 YES manual up                	up
Vlan1                  unassigned  	YES unset  administratively down down
R1#  show ipv6 interface brief
GigabitEthernet0/0/0   	[up/up]
	FE80::201:C9FF:FE89:4501
	2001:DB8:ACAD:10::1
GigabitEthernet0/0/1   	[up/up]
	FE80::201:C9FF:FE89:4502
	2001:DB8:FEED:224::1
Vlan1                      [administratively down/down]
	unassigned
R1#

Работа с таблицей маршрутизации роутера

Вызов таблицы маршрутизации выполняется посредством ввода команды: show ip route . Здесь будут отображены все сети, которые доступны данному маршрутизатору, метрика и шлюза. Краткая запись команды выглядит, как sh ip ro . После команды могут быть также указываться определенные параметры, например sh ip ro ospf – для просмотра соответствующей маршрутизации. Очистка таблицы маршрутизации выполняется с помощью Clear up route , после чего указывается адрес сети (например, Clear up route 1.1.1.1 ).

Взаимодействие с флэш-памятью и NVRAM

Для роутеров Cisco актуальны три программы:

  • ROM монитор для загрузки и отладки;
  • Boot ROM;
  • система во флэш – установленная самостоятельно.

Параметры записаны в NVRAM. Оперативная память предназначена для сохранности данных, при этом выполнение IOS идет из ROM. При работе с IOS 9.1 важно знать, что пароль здесь задается командой enable password , но никак не enable secret . Просмотр флэша выполняется с помощью команды show flash all . В командной строке выглядит это следующим образом:

    System flash directory:
File Length Name/status
     addr fcksum ccksum
1    3243752 igs-i-l.110-1
0x40 0xB5C4 0xB5C4
[3243816 bytes used, 950488 available, 4194304 total]
4096K bytes of processor board System flash (Read ONLY)
Chip Bank Code Size Name
1 1 89A2 1024KB INTEL 28F008SA
2 1 89A2 1024KB INTEL 28F008SA
3 1 89A2 1024KB INTEL 28F008SA
4 1 89A2 1024KB INTEL 28F008SA
Executing current image from System flash

Посмотреть записи флэш: show flash err . Копирование информации из флэш на tftp делаем с помощью copy flash tftp . Здесь мы получим мэсэндж о том, что нужно ввести имя сервера, изначальное и результирующее имена файла (файл с правами 666).

Делаем копию настроек параметров на tftp: copy startup-config/running-config tftp

    Router#copy tftp.
Router#copy tftp
Router#copy tftp flash
**** NOTICE ****
Flash load helper v1.0
This process will accept the copy options and then terminate
the current system image to use the ROM based image for the copy.
Routing functionality will not be available during that time.
If you are logged in via telnet, this connection will terminate.
Users with console access can see the results of the copy operation.
---- ******** ----
[There are active users logged into the system]
Proceed? [confirm]y
System flash directory:
File Length Name/status
1 5010180 c2500-ras-113.6
[5010244 bytes used, 3378364 available, 8388608 total]
Address or name of remote host 172.16.150.2
Source file name? c2500-ras-113.6 name of file in flash
Destination file name [c2500-ras-113.6]y
Accessing file 'c2500-ras-113.6' on 172.16.150.2...

Проверка, записан ли файл на TFTP сервер.

Загрузка настроек с TFTP: copy tftp startup-config/running-config.

При копировании из TFTP во флэш (copy tftp flash ) важно, чтоб было достаточно свободной памяти. Если выполнение IOS проводится из flash, то проводится новая загрузка. Затем сохраняем конфигурацию copy run start . Для загрузки из ROM IOS в регистре конфигурации задается значение 0-0-0-1.

Показать регистр конфигурации: show version (в основном, это загрузочные настройки роутера: дата последней загрузки, версия IOS, название файла IOS, модель маршрутизатора, объем памяти на flash и оперативной). Команду можно писать сокращенно sh ver .

Проверка контрольной суммы проводится вводом verify flash .

Еще раз выполнить файл конфигурации: configure memory .

Очистка конфигурации: erase startup .

Показать текущую/загрузочную конфигурацию: show run/start .

В NVRAM будут сохранены только несовпадающие со значением по умолчанию параметры. Значения по умолчанию могут отличаться для различных версий. При неполадках удобно использовать сохраненный на TFTP и загруженный с него файл конфигурации, IOS.

Debug также представляет полезные команды для настройки маршрутизатора. Здесь вы сможете посмотреть подробные данные, касающиеся конкретного протокола, службы, приложения. К примеру, debug ip route сообщит о появлении нового или удалении старого маршрута из роутера.